11 December 2007

ReSharper and Visual Studio crash on x64

For those who experience problems running ReSharper on x64 machines, here is the bug description on Microsoft Connect.


It turns out that this crash is the result of a bug in the Wow64 layer of Windows x64 (XP/2003 – it has been fixed in Vista x64) and only manifests itself when another app globally hooks all Windows messages.
We are currently working with the Windows servicing folks to get a hotfix produced.


Updated 13 Feb:
Deep in the comments to the aforementioned request there is information about how to obtain hotfix:

If you are experiencing this issue you will need to contact Microsoft Customer
Service & Support (http://support.microsoft.com) and ask for the Windows
Hotfix with ID 947841. If you have any difficulty in obtaining the patch
ask the CSS representative to contact me (Sean Laberee).

I am also pleased to announce that we have created a workaround in VS 2008 SP1 which eliminates this problem and the need for the patch. That workaround is queued for checkin to our build process and will be available in the Beta of the service pack.

And also:

A quick update on the windows patch. I've confirmed with our support team that if you call in for this hotfix you will not be charged. They will set up a "Hot Fix" case for you. I've also received a report that there was some confusion as to whether this fix is for Win2003 or XP. I've confirmed that this fix does in fact apply to both releases.

6 comments:

timores said...

Hi,

That would be great. I have a crash under Win2K3 x64 on each exit of VS or when launching a 2nd instance of VS. Or when launching Management Studio.
Could you post here when the hotfix is available ? Thanks.

Jean-Marie

Anonymous said...

Anything new on the x64 crash/fix? Its killing me.

Garick Newtzie said...

Still looking for an update on this. It's happening on vs 2008 and xp64 also.

Anonymous said...

I had a similar issue (VS2008 crashing on XP64 on the Find dialog). I'm not running Resharper. However, I am running Ultramon, which had a process called RTSHookInterop.exe. Killing Ultramon (and thus this process) got rid of the VS crashing isues.

Anonymous said...

According to this article, you can call support for free and get the hotfix:

http://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID=311712

I haven't gotten the hotfix yet, but I am working on it.

Silmaril said...

u can request hotfix here https://support.microsoft.com/contactus2/emailcontact.aspx?scid=sw;en;1414&WS=hotfix

just type 947841 in "Product and version affected" textbox